SPARKY FORUM

Recent Posts

Pages: 1 ... 8 9 [10]
91
PIANO HI-FI DAC / Re: Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by sparkyadmin on January 23, 2017, 09:21:29 PM »
Dear Team,

    Can you confirm which DAC you are using is it piano 2.0 or 2.1 .Can you please attach one image of your setup.

With Regards
Sparky Admin
92
PIANO HI-FI DAC / Re: Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by thomas on January 23, 2017, 05:23:54 AM »
I did select the Allo Piano DAC after having enabled I2S. But still not getting any sound out of it.

Anything that I can measure or check further either on the Piano DAC or the Raspberry? And whats the purpose of the onboard compatibility switch?
93
PIANO HI-FI DAC / Re: Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by sparkyadmin on January 23, 2017, 05:10:12 AM »
Dear Team,

   After enabling I2S dac you need to select DAC model as Allo piano then you need to save.

With Regards
Sparky Admin
94
PIANO HI-FI DAC / Re: Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by thomas on January 23, 2017, 03:34:28 AM »
Yes I've enabled that option in Volumio.
Please note that the log outputs from above are all using Libreelec.

Is there any way to ensure that there aren't hardware issues? Either from the Pi itself or the DAC?
95
PIANO HI-FI DAC / Re: Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by sparkyadmin on January 23, 2017, 03:14:01 AM »
Dear Team,

    Have you enabled I2S DAC option as shown in the below link.If not enabled please enable and check the status.

http://61.12.17.162:9098/sparky/volumio.JPG

With Regards
Sparky Admin

96
PIANO HI-FI DAC / Allo Piano Dac 1.1 & Raspberry Pi 3 Model B, no sound
« Last post by thomas on January 23, 2017, 02:25:34 AM »
Hi Allo team,
on weekend I received my Allo Piano Dac 1.1 along with the Kali board. First thanks for the really quick delivery!

But I couldn't make the Dac work. I've mounted it to my Pi board without the Kali board first, using the Allo power adapter.

As Pi images I've tried Libreelec 7.95.1 Beta and Volumio 2.041. Everything is connected and so far setup fine, that I can select the Pianao DAC within the Libreelec interface as well as in the Volumio interface. But no sound is coming through, neither through the RCA connectors nor through the headphone jack.

Before describing my setup further, one question: What is the on board Pi Compatibility switch for? Nowhere found a description of its purpose and when to switch to which position.

Here is my setup for Libreelec
in /flash/config.txt appened:
Code: [Select]
dtoverlay=allo-piano-dac-pcm512x-audio
dtdebug=1

The output of vcdbg log msg is:
Code: [Select]
dtdebug: Opened overlay file 'overlays/allo-piano-dac-pcm512x-audio.dtbo'
Loaded overlay 'allo-piano-dac-pcm512x-audio'
dtdebug: Found fragment 0 (offset 36)
dtdebug: merge_fragment(/soc/i2s@7e203000,/fragment@0/__overlay__)
dtdebug:   +prop(status)
dtdebug: merge_fragment() end
dtdebug: Found fragment 1 (offset 112)
dtdebug: merge_fragment(/soc/i2c@7e804000,/fragment@1/__overlay__)
dtdebug:   +prop(#address-cells)
dtdebug:   +prop(#size-cells)
dtdebug:   +prop(status)
dtdebug: merge_fragment(/soc/i2c@7e804000/pcm5142@4c,/fragment@1/__overlay__/pcm5142@4c)
dtdebug:   +prop(#sound-dai-cells)
dtdebug:   +prop(compatible)
dtdebug:   +prop(reg)
dtdebug:   +prop(status)
dtdebug: merge_fragment() end
dtdebug: merge_fragment() end
dtdebug: Found fragment 2 (offset 316)
dtdebug: merge_fragment(/soc/sound,/fragment@2/__overlay__)
dtdebug:   +prop(compatible)
dtdebug:   +prop(i2s-controller)
dtdebug:   +prop(status)
dtdebug: merge_fragment() end

The output of dmesg is:
Code: [Select]
snd-allo-piano-dac soc:sound: ASoC: CPU DAI (null) not registered
snd-allo-piano-dac soc:sound: snd_soc_register_card() failed: -517
snd-allo-piano-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered
snd-allo-piano-dac soc:sound: snd_soc_register_card() failed: -517
snd-allo-piano-dac soc:sound: pcm512x-hifi <-> 3f203000.i2s mapping ok

The output of lsmod is:
Code: [Select]
Module                  Size  Used by
hci_uart               15605  1
btbcm                   5315  1 hci_uart
bluetooth             291488  3 hci_uart,btbcm
brcmfmac              181893  0
snd_soc_pcm512x_i2c     2051  1
snd_soc_pcm512x        16692  1 snd_soc_pcm512x_i2c
snd_soc_bcm2835_i2s     5123  2
snd_soc_allo_piano_dac     2432  0
brcmutil                4893  1 brcmfmac
snd_soc_core          104527  3 snd_soc_pcm512x,snd_soc_allo_piano_dac,snd_soc_bcm2835_i2s
cfg80211              246082  1 brcmfmac
snd_pcm_dmaengine       2943  1 snd_soc_core
snd_pcm                68095  4 snd_soc_pcm512x,snd_pcm_dmaengine,snd_soc_allo_piano_dac,snd_soc_core
snd_timer              17690  1 snd_pcm
snd                    41825  3 snd_timer,snd_soc_core,snd_pcm
bcm2835_gpiomem         2716  0
i2c_bcm2835             5101  0

The output of amixer -c 0 info is:
Code: [Select]
Card hw:0 'PianoDAC'/'PianoDAC'
  Mixer name    : ''
  Components    : ''
  Controls      : 20
  Simple ctrls  : 19

The output of aplay -l is:
Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: PianoDAC [PianoDAC], device 0: Piano DAC HiFi pcm512x-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The output of aplay -L is:
Code: [Select]
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=PianoDAC
    PianoDAC,
    Default Audio Device
sysdefault:CARD=PianoDAC
    PianoDAC,
    Default Audio Device

Checking with amixer I saw the the volume for Digital was set to 100%. All other mixer options do not seem to be relevant, right?
Is there anything else that I need to enable? Reading about the device tree stuff it looks like explicitly enabling i2s isn't needed.

Any help is very welcome!
97
PIANO HI-FI DAC / Re: Allo Piano Dac 2.0 with Kali - Problems with setup
« Last post by sparkyadmin on January 22, 2017, 09:39:37 PM »
Dear Team,

   Can you please explain the board assembly scenario.If possible please send one image of that.

With Regards
Sparky Admin
98
PIANO HI-FI DAC / Allo Piano Dac 2.0 with Kali - Problems with setup
« Last post by soesas on January 19, 2017, 05:32:27 AM »
Hi,
I am pretty new to the whole hifiberry topic so bear with me.
I ordered the following setup: Allo Kali Reclocker with Piano 2.0 Dac together with the ALlo Power Supply.
It all runs on a RaspiPi 3 with the official 7" screen.

The first problem was that the spacers to mount the DAC on the Pi did not fit - their diameter is too big. That was a bit of a shame because I thought I bought a neat all in  one package.
That aside the setup is pretty straight forward.
However when I boot my system get the small colored square in the upper right corner which apparently indicates a lack of power. I assumed that the Allo Power supply powers the whole system (thus in my case Pi+screen+DAC+Kali) is that not the case???
99
PIANO HI-FI DAC 2.1 / Re: unix app > where to download?
« Last post by sparkyadmin on January 19, 2017, 05:06:18 AM »
Dear Team,

    Please find the link for the same

http://61.12.17.162:9098/sparky/PUREPATH-PROCESS-FLOW_PianoDAC_2.doc

With Regards
Sparky Admin
100
PIANO HI-FI DAC 2.1 / Re: unix app > where to download?
« Last post by sparkyadmin on January 19, 2017, 04:55:34 AM »
Dear Team,

     Due to file size we have forwarded to mail ID.

With Regards
Sparky Admin
Pages: 1 ... 8 9 [10]